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Aula 2 – Validação Funcional 

Se fossemos para a banca, testar o componente, colocaríamos fios 
nas entradas e saídas. Injetaríamos sinais de estímulo nos fios de 
entrada e conectaríamos um osciloscópio nos fios de saída, 
permitindo a visualização do comportamento destes. 

Como não temos o componente disponível fisicamente, mas sim um 
modelo deste, utilizamos simulação para validar o seu 
funcionamento. 

Como tudo em VHDL é componente, criamos um artifício em que o 
componente a ser testado (mux2x1) passa a ser visto como um 
subcomponente do componente de teste (testbenchmux2x1). 

Obs: Ao longo do texto, selecionar significa clicar uma vez! 



Introdução à VHDL                           Profa.Luiza de Macedo Mourelle                           2 

A

B

S

C

mux2x1

testbenchmux2x1

sigA

sigB

sigS

sigC

Dessa forma, a simulação do componente testbenchmux2x1 permite 
gerar os estímulos (sigA, sigB, sigC) para o mux2x1 e observar o 
resultado obtido (sigS). 

Deve-se observar que A, B, C e S são sinais internos do mux2x1, 
acessíveis através de sigA, sigB, sigC e sigS, respectivamente! 
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O componente testbenchmux2x1 tem como característica a ausência 
de sinais de interface:  

entity testbenchmux2x1 is
end testbench;

Como testbenchmux2x1 é constituído pelo componente mux2x1, sua 
descrição será necessariamente estrutural: 

architecture estrutural of testbenchmux2x1 is

component mux2x1
port (A,B,C: in bit; S: out bit);
end component;

signal sigA,sigB,sigC,sigS: bit;
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No corpo da arquitetura do testbenchmux2x1, instanciamos o 
componente a ser testado (componente), como sendo do tipo mux2x1, 
e especificamos os estímulos a este ao longo do tempo: 
begin

componente: mux2x1 port map(sigA,sigB,sigC,sigS);
sigA <= ‘0’, ‘1’ after 10 ns, ‘0’ after 15 ns;
sigB <= ‘1’, ‘0’ after 12 ns, ‘1’ after 17 ns;
sigC <= ‘0’, ‘1’ after 5 ns, ‘0’ after 13 ns;

end estrutural;

Observe que sigS não é acionado, uma vez que está associado à 
resposta do componente e não a um dos estímulos! 

A sequência de atribuições é escalonada no tempo, tendo como 
referência o tempo t = 0, i.e. sigA assume ‘0’ em t = 0ns, ‘1’em t = 
10ns e ‘0’em t = 15ns, logo 5ns após a última atribuição (‘1’)! 
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Para a simulação, vamos utilizar o simulador Modelsim-Intel FPGA 
Starter Edition (https://www.intel.com/content/www/us/en/software/
programmable/quartus-prime/model-sim.html), disponível 
gratuitamente para Windows e Linux. 

Para ter acesso à área dos arquivos, é necessário se registrar junto à 
Intel FPGA, para obter um nome de usuário e uma senha, assim que 
fizer acesso à página. 

Há dois arquivos a serem instalados: ModelSimProSetup e 
ModelSimProSetup-part2. Em seguida, execute ModelsimProSetup, 
que irá utilizar o ModelSimProSetup-part2 automaticamente. 

No Windows, o simulador (modelsim.exe) encontra-se na pasta 
intelFPGA_pro\20.2\modelsim_ase\win32aloem! 



Introdução à VHDL                           Profa.Luiza de Macedo Mourelle                           6 

A figura abaixo corresponde à janela de abertura do Modelsim. Nela, 
identificamos a guia de comandos (topo), a janela da biblioteca 
(Library) e a janela de mensagens (Transcript), na parte inferior. 
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O primeiro passo é criar um projeto, que irá agregar todos os 
componentes associados a ele, posteriormente: 

Ø  File>New>Project 
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Ø  Project Name: insira o nome do projeto, e.g. projetomux2x1 

Ø  Project Location>Browse... e selecione a pasta onde o projeto irá 
ser armazenado, utilizando uma pasta diferente da que contém o 
Modelsim (intelFPGA_pro); neste momento, podemos criar a 
pasta com o nome ProjetoMux2x1 

Ø Default Library: work 

Ø Copy Settings From: modelsim_ase/modelsim.ini 

Selecione Reference Library Mappings. 
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No exemplo, o arquivo estará na pasta C:/Users/ldmm/Documents/
ProjetoMux2x1, com o nome projetomux2x1.mpf. Nunca o abra! 

Ø OK 
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Feche a janela Add items to the Project. 

Agora temos uma nova janela, designada Project, ao lado de Library. 
Selecione a janela Library, onde poderá observar a presença da pasta 
work, com a informação de que está vazia (empty). É nessa 
biblioteca que todos os componentes que comporão o mux2x1 serão 
montados. Não faça alterações nessa pasta! 

Agora vamos criar o nosso primeiro componente. Selecione a janela 
Project e, em seguida: 

Ø  File>New>Source>VHDL 

Uma nova janela (Untitled-1.vhd) é disponibilizada à direita de 
Project, onde iremos editar a descrição da entidade do mux2x1, 
conforme elaborado anteriormente. 
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Em seguida, vamos salvá-lo: 

Ø  File>Save As... 

Na janela Save As, observe que a pasta corresponde à que foi criada 
para o projeto (ProjetoMux2x1). Atribua o nome ao componente, i.e. 
mux2x1, e salve na pasta do projeto. Não guarde nada na pasta work! 

Selecione a janela Project e, em seguida: 

Ø  Project>Add to Project>Existing File... 

Na janela Add file to Project, no campo File Name, insira o nome do 
arquivo que contém a descrição da entidade do componente mux2x1, 
i.e. mux2x1. Você também pode utilizar o botão Browse, que 
permitirá visualizar a pasta ProjetoMux2x1, onde se encontra o 
arquivo mux2x1.vhd. 
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Na janela Project, observe que o arquivo torna-se visível, com um 
ponto de interrogação em Status, significando que ainda não foi 
compilado. O processo de compilação verifica se o código está 
correto e, neste caso, gera a representação interna utilizada pelo 
simulador. Selecione o arquivo mux2x1 e compile-o: 

Ø Compile>Compile Selected 

Na janela Transcript, aparece a mensagem “Compile of mux2x1 was 
successful” e, na janela Project, o atributo Status recebe ✓. 

Vamos introduzir um erro no modelo, para ver como tratá-lo. Na 
janela de edição, retiramos o ; ao final da linha 2: 

entity mux2x1 is
port (A,B,C: in bit; S: out bit)
end mux2x1;
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Em seguida, vamos salvá-lo: 

Ø  File>Save 

Na janela Project, observe que o arquivo mux2x1 apresenta um ? no 
atributo Status, indicando que requer compilação. Selecione o 
arquivo mux2x1 e o compile novamente: 

Ø Compile>Compile Selected 

Na janela Transcript, aparece a mensagem “Compile of mux2x1 
failed with 1 errors” e, na janela Project, o atributo Status recebe ✗. 
Ao selecionar duas vezes a mensagem, aparece a janela “mux2x1 – 
Unsuccessful Compile”, indicando o erro na linha (3) e sugerindo 
que seja a falta do ;. 
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Feche a janela “mux2x1 – Unsuccessful Compile” e retorne para a 
janela de edição. Observe que o erro não está na linha 3, mas nas 
imediações desta. Neste caso, ao final da linha 2. Vamos corrigir, 
incluindo o ; e, em seguida, salvá-lo: 

Ø File>Save 

Na janela Project, selecione o arquivo mux2x1 e compile-o 
novamente: 

Ø Compile>Compile Selected 

Na janela Transcript, aparece a mensagem “Compile of mux2x1 was 
successful” e, na janela Project, o atributo Status recebe ✓. 
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Na janela Library, observe que a work não está mais vazia. Selecione 
o botão + ao lado da work. Agora temos, nesta biblioteca, a entidade 
(E) mux2x1. Novamente, não faça qualquer alteração/manipulação 
em qualquer elemento desta janela! Você pode somente consultar, 
selecionando o botão +. 

Agora, vamos especificar a arquitetura do componente mux2x1. 
Selecione a janela Project e, em seguida: 

Ø  File>New>Source>VHDL 

Observe que uma nova janela de edição aparece (Untitled-1.vhd), 
mantendo a anterior (mux2x1). Na nova janela, vamos editar a 
descrição da arquitetura do mux2x1, no domínio comportamental 
algorítmico, conforme elaborado anteriormente. 
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Ø  File>Save As... 

Vamos atribuir o nome mux2x1algoritmica para o arquivo que irá 
conter a especificação da arquitetura algoritmica. 

Selecione a janela Project e, em seguida: 

Ø  Project>Add to Project>Existing File... 

Na janela Add file to Project, no campo File Name, insira o nome do 
arquivo que contém a especificação da arquitetura algorítmica do 
componente mux2x1, i.e. mux2x1algoritmica (sem acento!). 

Na janela Project, selecione o arquivo mux2x1algoritmica e, em 
seguida, compile-o: 

Ø Compile>Compile Selected 
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Na janela Transcript, aparece a mensagem “Compile of 
mux2x1algoritmica was successful” e o atributo Status recebe ✓. 

Na janela Library, selecione o botão + da work. Selecione o botão +  
junto à entidade (E) mux2x1. Agora temos a arquitetura (A) 
algoritmica do mux2x1. Novamente, não faça qualquer alteração/
manipulação em qualquer elemento desta janela! Você pode somente 
consultar, selecionando o botão +. 

Pronto, o componente mux2x1 já está pronto na biblioteca work! O 
próximo passo é verificar se o componente mux2x1 funciona de 
acordo com a tabela verdade, apresentada anteriormente. 

Para tal, vamos criar o componente testbenchmux2x1 já elaborado. 
Veja que o projeto continua o mesmo (projetomux2x1.mpf), já que 
testbenchmux2x1 é parte desse projeto! 
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Selecione a janela Project e, em seguida: 

Ø  File>New>Source>VHDL 
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Ø  File>Save As... 

Na janela Save As, atribua o nome ao componente, i.e. 
testbenchmux2x1, e salve-o. 

Selecione a janela Project e, em seguida: 

Ø  Project>Add to Project>Existing File... 

Na janela Add file to Project, no campo File Name, insira o nome do 
arquivo que contém a descrição da entidade e arquitetura do 
componente testbenchmux2x1, i.e. testbenchmux2x1. 

Na janela Project, selecione o arquivo testbenchmux2x1: 

Ø Compile>Compile Selected 
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Na janela Transcript, aparece a mensagem “Compile of 
testbenchmux2x1 was successful” e o atributo Status recebe ✓. 

Na janela Library, selecione o botão + ao lado da work. Agora temos, 
nesta biblioteca, a entidade (E) testbenchmux2x1. Selecione o 
botão + junto à entidade e teremos a arquitetura (A) estrutural do 
testbenchmux2x1. 

No caso do testbenchmux2x1, elaboramos a entidade e a arquitetura 
em um mesmo arquivo (testbenchmux2x1). No processo de 
compilação, as duas especificações são identificadas para a 
montagem da biblioteca work! 

A vinculação da arquitetura à entidade se faz a partir do cabeçalho 
em architecture, onde se declara o nome da arquitetura 
(estrutural) e a qual entidade corresponde (testbenchmux2x1). 
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A simulação se faz a partir do testbenchmux2x1, que é onde o 
componente a ser testado é invocado e os estímulos especificados! 

Na guia de comandos, no topo da página: 

Ø  Simulate>Start Simulation... 

Na janela Start Simulation, selecione o botão + ao lado de work e, 
em seguida, selecione a entidade testbenchmux2x1.No campo 
Resolution, escolha ns (nanosegundos). 

Ø OK 

Aguarde até que a janela sim esteja disponível do lado esquerdo, ao 
lado de Library e Project. 
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Observe que, na janela de edição, temos uma aba Wave, que 
corresponde à janela onde os resultados de simulação serão 
amostrados na forma de ondas quadradas. 

Na janela sim, selecione o testbenchmux2x1:

Ø Add>To Wave>All items in the region 

Na janela Wave, primeira coluna, aparecem os sinais descritos no 
testbenchmux2x1. Na segunda coluna, temos os valores binários 
dos respectivos sinais. A terceira coluna servirá para amostrar as 
formas de onda ao longo do tempo de simulação. 
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Ø  Simulate>Runtime Options 

Ø  Selecione Binary 

Ø Default Run = 100 ns 

Observe se o campo Iteration Limit é diferente de 0. 

Ø OK 
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Ø  Simulate>Run>Run 100 

Selecione a terceira coluna da janela Wave e selecione a lupa +, 
localizada na guia de comandos, o que permitirá aumentar o grau de 
visão. Ao colocar o cursor (linha amarela vertical) sobre uma 
determinada posição (selecionando essa posição), os valores 
correspondentes aos sinais são amostrados na segunda coluna. 

Observe que as formas de onda terminam em 100 ns! 

Verifique se, para cada combinação dos sinais de entrada, a resposta 
corresponde à especificação do componente! 
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Para terminar a simulação: 

Ø  Simulate>End Simulation 

Para sair do Modelsim, selecione a janela Project e, em seguida: 

Ø  File>Close Project 

Observe que a janela Project é fechada. Em seguida: 

Ø  File>Quit 

É importante que se feche o projeto antes de sair do aplicativo. Isto 
faz com que o Modelsim feche os arquivos de simulação 
corretamente, a fim de abrí-los da próxima vez sem problemas! 
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Vamos agora incorporar as outras descrições de arquitetura do 
mux2x1: fluxodedados e estrutural. Para tal, vamos executar o 
Modelsim novamente, só que, agora, ao invés de criar um projeto, 
vamos invocar o projeto que foi criado anteriormente: 
projetomux2x1.mpf. 

Ø  File>Open 

Na janela Open File, vá para a pasta ProjetoMux2x1. Selecione 
Project Files, no campo ao lado de Nome, e, em seguida, selecione 
projetomux2x1.mpf. 

Ø Abrir 
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A janela Project torna-se disponível e os arquivos vinculados  ao 
projeto projetomux2x1 são visualizados. 
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Ø  File>New>Source>VHDL 

Reproduzimos, então, o modelo em fluxo de dados já elaborado. 
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Ø  File>Save As... 

Na janela Save As, no campo Nome, inserir mux2x1fluxodedados. 

Selecione a janela Project e, em seguida: 

Ø  Project>Add to Project>Existing File... 

Na janela Add file to Project, no campo File Name, inserir 
mux2x1fluxodedados. 

Ø OK 
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Na janela Project, o arquivo mux2x1fluxodedados torna-se 
disponível para ser compilado. 
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Selecione a janela Project, em seguida, selecione o arquivo 
mux2x1fluxodedados e, finalmente: 

Ø Compile>Compile Selected 

Na janela Transcript, aparece a mensagem “Compile of 
mux2x1fluxodados was successful” e, na janela Project, o atributo 
Status recebe ✓. 
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O próximo passo é simular, utilizando o mesmo testbenchmux2x1 já 
descrito e utilizado para a arquitetura algorítmica: 

Ø  Simulate>Start Simulation... 

Na janela Start Simulation, selecione selecione o botão + ao lado de 
work e, em seguida, selecione (E) testbenchmux2x1: 

Ø Resolution = ns 

Ø OK 

Aguarde a janela sim ser disponibilizada ao lado de Library e 
Project!  
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A simulação do mux2x1 para cada uma dessas arquiteturas utiliza o 
mesmo testbenchmux2x1, uma vez que este simplesmente fornece 
estímulos às entradas do mux2x1, independentemente da sua 
especificação interna (arquitetura).  

Obviamente, o mux2x1 deverá responder da mesma forma, 
independentemente da descrição interna.  

Por isso temos somente um testbench para cada entidade (entity) 
e não para cada arquitetura (architecture) de qualquer 
componente! 
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Na janela sim, selecione o testbenchmux2x1:

Ø Add>To Wave>All items in the region 

Na janela Wave, aparecem os sinais descritos no testbenchmux2x1 
(primeira coluna). Na segunda coluna, temos os valores binários dos 
respectivos sinais. A terceira coluna servirá para amostrar as formas 
de onda ao longo do tempo de simulação. 

Observe que a janela é idêntica à da simulação da arquitetura 
algorítmica. Isto porque o componente é o mesmo (mux2x1), mas 
com uma outra descrição (fluxo de dados)! 
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Ø  Simulate>Runtime Options 

Ø  Selecione Binary 

Ø Default Run = 100 ns 

Observe se o campo Iteration Limit é diferente de 0. 

Ø OK 
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Ø  Simulate>Run>Run 100 

Selecione a terceira coluna da janela Wave e selecione a lupa +, 
localizada na guia de comandos, o que permitirá aumentar o grau de 
visão. Ao colocar o cursor (linha amarela vertical) sobre uma 
determinada posição (selecionando essa posição), os valores 
correspondentes aos sinais são amostrados na segunda coluna. 

Observe que as formas de onda terminam em 100 ns! 
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Observe que o resultado é idêntico ao obtido a partir da simulação da 
descrição algorítmica! 
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Para terminar a simulação: 

Ø  Simulate>End Simulation 

Para sair do Modelsim, selecione a janela Project e, em seguida: 

Ø  File>Close Project 

Observe que a janela Project é fechada. Em seguida: 

Ø  File>Quit 

É importante que se feche o projeto antes de sair do aplicativo. Isto 
faz com que o Modelsim feche os arquivos de simulação 
corretamente, a fim de abrí-los da próxima vez sem problemas! 
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Pode-se elaborar todo um projeto em um único arquivo, de onde o 
compilador extrai todos os elementos para a construção da biblioteca 
work. No entanto, qualquer alteração que seja necessária, fará com 
que todo o arquivo seja manipulado, o que pode ser inconveniente 
quando o tamanho do projeto for considerável. A utilização de um 
arquivo por componente facilita a identificação e manipulação do 
componente na pasta do projeto. 

Outro aspecto é que a todo e qualquer componente, se faz 
corresponder uma única entidade e, para cada entidade, pode-se 
associar mais de uma arquitetura. No caso do mux2x1, elaboramos 
uma algorítmica, uma fluxo de dados e uma estrutural. No entanto, 
só temos uma única entidade. O nome da arquitetura é genérico e não 
está associado a qualquer modelo em especial. 


